The biggest little game update - LEWD

edited June 2014 in Blog Posts

imageThe biggest little game update - LEWD

There's no new content besides some portraits, and no new game mechanics, but just about all of the game server was recoded. Why all the work for no change right now? Well it

Read the full story here


  • wow that new portraits sure looks awesome \o/

    i've gave the new build a try and i've met just a couple of odd things

    first is the encounter with ᔕᕈᗩᒎᔕᔕ ᗩᒎᔕᔕ as a female character, the first time i talk to her she asks you to use the injector, when you haven't adquired it yet, instead of her challenging you to a race, but the quests log shows this last as "Follow the Female Taur" (screenshot here )

    this happens at position 7, 14, the place where you must go to collect the lost shirt for Kaeleigh (i started another game later and the encounter with Spajss happened anywhere else, but with the same results)
    then if i leave without using the injector and move north to 6, 14 it makes an attemp to open a dialog window, but it closes inmediately

    after that i committed suicide (touch fluffy tail ;) ), started a clone, moved to 6, 14 and the correct dialog with Spajss appeared, although it doesn't turns the quest as completed, and the same dialog appears everytime i move into this position

    as a male, first i got the injector so i could end the dialog with Spajss by using it, although i was given the follow the taur quest too, wich i could complete by moving to 6,14
    then i found the shirt in a ramdon spot, but i wasn't given the option to give it to Kaeleigh, i asume the quest is still a wip

    the second one is that the first time you talk to Lia and ask "How did I get here?", the dialog doesn't show (blank window), but the next time you ask she explains that she already told you

    i hope i made myself clear with the explanation
    that's all for now, except a typo that i'll point in the forum thread

    i hope you've recovered from your injury
  • Ah I thought the injector scenes coming up wrong was something wrong in the scene's logic that I already fixed. I see there is something wrong with the engine itself that needs some looking into.

    Thanks for the report on those. I'll look into them some more tomorrow~
  • I think I got those fixed now.
  • indeed, but i fear there are some new odd things happening :(

    when meeting Macsen, Kaeleigh and Spajss Ajss for the first time, the dialog follows as you've already meet them before, and if you visit them again later it's like the first time you met, at random

    for example, i start a new female character, and when visiting Kaeleigh for the first time, after receiving the quest "A new best friend" from Gail, this is the dialog
    “Hi again! Did you get me a shirt yet?”...
    but if i visit her a couple of times i get the right scene
    i get this dialog too as a male

    i could reproduce the problem with Macsen just once, happens always with Kaeleigh, and it's more random with Spajss Ajss

    another oddity concerns the libido system that i think is working just for males, nor females or genderless characters

    another one is about the portraits; most of the times the image's width is the same as the npc stats panel, but very few times it's a little shorter (

    lastly is the "Follow the Female Taur" quest that now i can't complete at 6,14

  • I just fixed a bunch with those first things. It was tracking completion of things wrong.

    I think the portrait changing must be something with your browser. That's weird and there's no code that should cause that.
  • great

    i'll check the browser thing

    now i have some troubles with dialogs
    the first one is that there is no answer options for the encounter with Gail, so i got stuck
    and the second i've seen is that all the options with the Luarane encounter are greyed out, as if i don't meet the requeriments, this happens both with the struggle and question answers
  • What character stuff did you have changed from the default to make all the Luarane options be greyed out?
  • i've just started a fresh male character, without changing any default option, nor assigning any point, and it happens
    just in case it was related to cache i did that too in a new private browser window and in other browser (firefox and chrome), with the same result
  • Hm...

    I tried a default character. Just putting in a name, then skipping to the end to play, and I don't get those issues with all options being greyed out for Luarane.

    Have you tried a hard refresh of the game page? (ctrl+f5)
  • Oh I'm seeing options just not showing up now. Huh.
  • I think it's fixed now.
  • it is b(^_^)d

    by the way, up till now i haven't found anything related to the rare game server crash
  • edited June 2014
    Best I can figure at the moment as it's related to the goo jar and android. Perhaps when you already have it.

    From what's logged, the crash is always when it's loading that for someone.

    But that's not the whole story, since when I try it, get one in my inventory, and it tries to roll the event again when I already have it, it's working perfectly fine...
  • Okay well, I think I'm close to finding it.

    I think it has to due with the Scenario queuing constantly queuing, running, ending something.

    I know it's getting into an infinite loop of trying to send a Scenario to a player, and I think that's why.

    And I think there's a problem with it rolling scenarios and putting one in a queue when two are rolled, when it should have stopping rolling when it hit on one.

    I changed some things that may fix both issues. I'll have to see if it crashes again before I know for sure.  It's been impossible for me to get it to crash intentionally.
  • good luck with it then
    let us now if we can help in any way
  • edited November 2015
    Disregard, I think I confused an issue with something left over from the saved game...
Sign In or Register to comment.